Home > java > Cannot change maven version in eclipse

Cannot change maven version in eclipse

January 10Hits:9
Advertisement

After failing to mvn package inside of eclipse but succeeding in the terminal, I realized that eclipse was running maven 3.3.3 while terminal was running 3.3.9. I attempted, and by all apparent accounts succeeded, to reconfigure eclipse by going to Eclipse -> Preferences -> Maven -> Installations and pointing to my 3.3.9 folder. I restarted eclipse and tried again but to no avail. Also, changes to the pom.xml file are not acknowledged when attempting to build. I've inserted inappropriate slashes and other characters and am only able to generate this error:

Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode)

I modified my pom file as per this recommendation but as I said, maven is not recognizing changes to the pom and I cannot get running mvn --version to produce 3.3.9 as it should. I've attached my pom below

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>com.javawebtutor</groupId> <artifactId>LoginWebApp</artifactId> <packaging>war</packaging> <version>1.0-SNAPSHOT</version> <name>LoginWebApp Maven Webapp</name> <url>http://maven.apache.org</url> <dependencies>     <dependency>         <groupId>javax.servlet</groupId>         <artifactId>servlet-api</artifactId>         <version>2.5</version>     </dependency>     <dependency>         <groupId>mysql</groupId>         <artifactId>mysql-connector-java</artifactId>         <version>5.1.30</version>     </dependency>     <dependency>         <groupId>junit</groupId>         <artifactId>junit</artifactId>         <version>4.10</version>     </dependency> </dependencies> <build>     <finalName>LoginWebApp</finalName>     <plugins>     <plugin>                   <groupId>org.apache.maven.plugins</groupId>       <artifactId>maven-war-plugin</artifactId>       <configuration>         <webXml>src\main\webapp\WEB-INF\web.xml</webXml>               </configuration>     </plugin>     </plugins> </build> 
Tags:java, eclipse, maven

Related Articles

  • Cannot change maven version in eclipseJanuary 10

    After failing to mvn package inside of eclipse but succeeding in the terminal, I realized that eclipse was running maven 3.3.3 while terminal was running 3.3.9. I attempted, and by all apparent accounts succeeded, to reconfigure eclipse by going to E

  • Updating maven project in eclipse with new maven archetypeFebruary 5

    Currently I'm working with the Eclipse IDE (Eclipse Java EE IDE for Web Developers, Luna Service Release 2 (4.4.2)). At the moment I have a maven Remote Catalog, that refers to a repository on a Nexus Repository Manager OSS. In this repository there

  • Cocoa vs Carbon versions of EclipseAugust 29

    Can someone tell me what's the difference between Cocoa and Carbon? I want to download Eclipse but I don't know which one to pick, I have option to choose Cocoa or Carbon. --------------Solutions------------- Cocoa supports features like spell checki

  • How to update maven version on ubuntu machine?September 20

    I am working on Ubuntu linux machine. When I open a terminal window and type : mvn -v I got the output: Apache Maven 2.2.1 (rdebian-1) Java version: 1.6.0_26 Java home: /usr/lib/jvm/java-6-sun-1.6.0.26/jre Default locale: en_US, platform encoding: UT

  • Getting Maven Version in JenkinsMarch 27

    Is there any way a Jenkins build can be aware of the Maven version number of a project after processing the POM? I've got some projects where versioning is controlled by Maven, and in a post-build job we'd like to create a Debian package and call som

  • Where can I find out if I have the 32-bit or 64-bit version of Eclipse?April 30

    Where can I find out if I have the 32-bit or 64-bit version of Eclipse? --------------Solutions------------- In Eclipse, go to Help -> About Eclipse -> Installation Details Click on 'Configuration' tab: Scroll down and look for osgi.arch in in textb

  • How to install most recent version of Eclipse via the TerminalJune 19

    I'm new to Linux and have just been given a VM of Oracle Linux to work with. I need to install Eclipse on it and, after a bit of research, discovered that this could most easily be done with the following command in the Terminal: sudo yum install ecl

  • Debian - newest version of EclipseMarch 23

    I use Debian Jessie (testing) and I have Eclipse 3.8. Newest version of Eclipse is 4.4. In Debian Sid (unstable) I have still Eclipse 3.8. How can I install newest version of Eclipse on this museum of software? ;) --------------Solutions-------------

  • Difference in creating a Spring/Hibernate/Maven project in Eclipse and through Command LineJanuary 22

    What is the difference in creating a Spring/Hibernate/Maven project in Eclipse using New > Project > Maven > Maven Project, and through Command Line using mvn archetype:generate? Thanks

  • Version of Eclipse for Android DevelopmentJanuary 31

    I'm having trouble choosing version of Eclipse for Android development. I downloaded Eclipse Mars 1, and it does not show ANDROID NEW so I have to know now what I download. I have read a few sites online and they said that you go to File > new > Pro

  • Maven build in Eclipse Luna IDEFebruary 17

    I want to develop a simple test program as maven project in eclipse IDE. What are the prerequisite and procedure to run this program. --------------Solutions------------- Check the answers from this post: Maven in Eclipse: step by step installation T

  • Why does my Maven build of Eclipse (Galileo) fail?January 28

    I am trying to build Galileo with Maven on Windows 10. The build being done at the DOS prompt not within Eclipse. The plugin requires org.mozilla.rhino but it fails download. Builds of all other versions Helios-Mars build perfectly ok In my parent po

  • Update Maven version in Ubuntu 8.1March 11

    My ubuntu has maven 2.0.9 version installed, but now i want to update to the newest version. Altough Im not the root, I have downloaded maven latest version, modified the M2_HOME in .bashrc file with sudo, but when i type in console mvn -version, the

  • How to tell apt-get to install another version of Eclipse?February 17

    apt-get installs Eclipse version 3.5 when I do this: sudo apt-get install eclipse-platform However I would like to install version 3.6. How can I do that? --------------Solutions------------- Eclipse 3.5 is the latest version in repositories.apt-get

  • How to install a complete version of Eclipse?March 9

    I am looking into installing Eclipse but I'm having a slight difficulty. Unlike Visual Studio eclipse needs some very odd addons and things that are on their website. Is there just a complete version where I can get everything immediately? I don't wa

  • How to choose gtk version for Eclipse RCP application in linux?February 20

    I have an Eclipse RCP application which I want to run in Linux environment that has multiple gtks installed. Is there a way to choose the gtk version against which I can run the application? Linux flavour: openSUSE Window Manager: iceWM gtk+ versions

  • Switch Maven version after installing from jpackage?June 6

    I've installed maven3 on CentOS from the JPackage repository. Problem is my installs also seem to have pulled in maven2 which is the default. Is there any way to switch /usr/bin/mvn to be maven3? perhaps using the alternatives application? (note: I c

  • What is the difference between Maven build and Maven build- in Eclipse?

    What is the difference between Maven build and Maven build- in Eclipse?January 21

    I am new to eclipse and programming , so probably a silly question. According to me build just makes jar file but maven install deploys it to local repo thats m2 . Also there are two options for build ->maven build and-> maven build.. Could u explai

  • Maven Compiling After Eclipse Clean OnlyJanuary 22

    I'm using Eclipse Mars 4.5.1, Maven 3.0.5, and Java 8. If I do the following: Eclipse Clean mvn compile Maven compiles fine. However if I run mvn clean compile I get a lot of errors that that don't make sense such as: [ERROR] /home/ole/Sandbox/math/f

  • Self-Contained Application Packaging for java swing maven project in eclipseJanuary 26

    I want to make a self-contained package (including jre 8). I have a Maven project developed in Eclipse. I have read that JavaFX has support for building towards different platforms (Windows, Mac, Linux). What is the best way forward? I know there is

Copyright (C) 2017 ceus-now.com, All Rights Reserved. webmaster#ceus-now.com 14 q. 0.530 s.