Home > other > Error trying to install mod_ruby using OPenSuse 11.1

Error trying to install mod_ruby using OPenSuse 11.1

March 8Hits:2
Advertisement

Hi I am installing this webserver OPs 11.1..I got this far

cd /tmp
wget http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
tar zxvf mod_ruby-1.2.6.tar.gz
cd mod_ruby-1.2.6/
./configure.rb --with-apr-includes=/usr/include/apr-1

error occurs right after executing the ./configure.rb - ......

{/usr/bin/env: python: No such file or directory}

Any assistance will be gladly appreciated

Answers

JASI0WEBSVR:/home/neim777 # cd /tmp
JASI0WEBSVR:/tmp # wget http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
--2009-03-12 11:28:11-- http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
Resolving www.modruby.net... 221.186.184.67
Connecting to www.modruby.net|221.186.184.67|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 110886 (108K) [application/x-tar]
Saving to: `mod_ruby-1.2.6.tar.gz.4'

100%[==================================================================================================================================>] 110,886 88.5K/s in 1.2s

2009-03-12 11:28:13 (88.5 KB/s) - `mod_ruby-1.2.6.tar.gz.4' saved [110886/110886]

JASI0WEBSVR:/tmp # cd mod_ruby-1.2.6/
JASI0WEBSVR:/tmp/mod_ruby-1.2.6 # ./configure.rb --with-apr-includes=/usr/include/apr-1
/usr/bin/env: ruby: No such file or directory
JASI0WEBSVR:/tmp/mod_ruby-1.2.6 #
Good Morning to everyone..I still need someones help.I looked and searched and butchered the Web looking for a solution..I know the answer is just to edit some file header.....but which file..

This is a new install which I am following Falko's how to build the perfect OpenSuse 11.1 server Error trying to install mod_ruby using OPenSuse 11.1

Please install the packages python and ruby.
Did that and did it again,,followed your instructions carefully..Same issue

yast -i apache2-devel ruby ruby-devel
RESOLVED! !!trying to install mod_ruby using OPenSuse 11.1

I reinstalled python and installed ruby 1.3.0 instead of 1.2.6

Tags:

Related Articles

  • Error trying to install mod_ruby using OPenSuse 11.1

    Error trying to install mod_ruby using OPenSuse 11.1March 8

    Hi I am installing this webserver OPs 11.1..I got this far cd /tmp wget http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz tar zxvf mod_ruby-1.2.6.tar.gz cd mod_ruby-1.2.6/ ./configure.rb --with-apr-includes=/usr/include/apr-1 error occurs right af

  • CentOS ISPconfig install, mod_ruby source not found.

    CentOS ISPconfig install, mod_ruby source not found.August 4

    http://www.howtoforge.com/perfect-server-centos-5.5-x86_64-ispconfig-2-p6 In step 12.3 When going to http://www.modruby.net all I get is 'It works'. Is there an update of these instruction?? Thanls for your time. --------------Solutions-------------

  • Install Lyx in OpenSuse - libboost_regex problemMay 2

    I am trying to install lyx in opensuse with sudo zypper in lyx However, I get the following error Problem: nothing provides libboost_regex.so.1.53.0()(64bit) needed by lyx-2.1.3-109.1.x86_64 Solution 1: do not install lyx-2.1.3-109.1.x86_64 Solution

  • winexe gives error "ERROR: Failed to install service winexesvc - NT_STATUS_ACCESS_DENIED"October 7

    I'm trying to do a remote execution on a windows host from Linux with winexe. I get the error: ERROR: Failed to install service winexesvc - NT_STATUS_ACCESS_DENIED The authenticated user should have administrator rights. What exactly does this error

  • Error while compiling/installing PHP with FPM for RPM on Centos 5.4 x64December 10

    I'm trying to make an RPM with PHP 5.3.1 and PHP-FPM 0.6 for CentOS 5.4. So far it goes quite well, but when rpmbuild gets to the installation phase it fails with the following error: Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.63379 + umask 022

  • Checking installed files in OpenSUSEJune 3

    How to check what files are installed by an installed package under OpenSUSE? --------------Solutions------------- For installed packages, there is a "Files" tab within the Software Management element of YAST, which lists what files were install

  • Error 302 when installing rake gemJanuary 21

    i try to install rake on my clean lenny server, i get the following error: Updating installed gems ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError) bad response Found 302 (http://gems.rubyforge.org/latest_specs.4.8) any advice here? th

  • installing Scilab in OpenSUSE 11.3February 26

    I want to install Scilab on OpenSUSE 11.3. Which repository is it located in? I cannot find it listed in the package manager. I have tried to install the rpm manually, but I cannot resolve the dependencies. --------------Solutions------------- Exactl

  • zlib error on gem install rails after rvm version switchDecember 12

    (Debian squeeze) rvm version: 1.10.0 I have just installed ruby 1.9.2-p290 using "rvm install 1.9.2" and made it default. However, I am getting this error when trying to install rails using rubygems. "gem install rails" worked fine on

  • Can not Install mod_ruby.

    Can not Install mod_ruby.April 16

    I'm install ISPConfig2 on CentOS 5.3 as instruction from howtoforge and stuck at "12.2 Installing mod_ruby" section. http://www.howtoforge.com/perfect-server-centos-5.3-i386-ispconfig-2-p6 Code: nano /etc/httpd/conf.d/ruby.conf LoadModule ruby_m

  • How do I resolve the Boot Camp error "Can't install windows support software."?May 12

    I have tried many times to download the Windows Support Software using BootCamp assistant on OSX Lion 10.7.4 ,every time after downloading about 650MB I get the error "Can't install windows support software." What should I do? I already installe

  • Error during "Make Install" while installing PlayerJanuary 1

    I want to install Player on Ubuntu Platform. I run configure. This is done successfully. When running sudo make install afterwards, I get the following error: Making install in replace make[1]: Entering directory `/home/khimya/player-2.1.2/replace' i

  • Error 110 while installing apps January 25

    Possible Duplicate: How do I fix "Unknown reason -110"? I have been getting 'error 110' while installing an app from the playstore. I have an HTC HD Desire. What does this error mean, and how can I fix it? --------------Solutions------------- Cl

  • How to install kdesudo in OpenSUSE 12.3June 28

    I'm hoping this is a stupid question with a simple answer, but I've been hunting around for half an hour and cannot find a way to install kdesudo in OpenSUSE 12.3. I need to use kdesudo because kdesu (which is pre-installed in OpenSUSE 12.3) is a bas

  • I fixed grub error after ubuntu install with cd fix, butDecember 8

    I fixed grub error after ubuntu install with cd fix, but now I am only booting to xp. How do I get ubuntu to boot ? --------------Solutions------------- If you are able to (boot from cd) then you will have successfully booted Ubuntu. However if you a

  • When installing pbc for Mylar, error: cannot find install-sh, install.sh, or shtoolMarch 27

    I am trying to install Mylar. http://css.csail.mit.edu/mylar/ The instructions advise that it requires several prerequisites: libreadline libgmp libpbc libcrypto++9 I believe I installed the first two correctly with apt-get. also libgmp-dev and libre

  • Error with FastCGI install on CentOS 6.5June 21

    I'm trying to setup FastCGI but keep getting the following error message: Installing : mod_fastcgi-2.4.6-2.el6.rf.x86_64 Non-fatal POSTIN scriptlet failure in rpm package mod_fastcgi-2.4.6-2.el6.rf.x86_64 semodule: SELinux policy is not managed or st

  • Error trying to install wine in Ubuntu 14.10: missing or conflicting packagesJanuary 21

    I already tried to install it with the terminal as well as with the ubuntu-software-center, but I always get this: This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a

  • Facing fatal error "unable to install grub" while installing UBUNTU 14.04January 22

    Recently I bought Dell laptop with i7 processor and Windows 8 is preinstalled.. I downloaded UBUNTU 14.04 and trying to install . But I am facing fatal error " Unable to install grub2". I tried several ways but no luck.. I tried the options pres

  • Can't install grub on MBR, encountered an error "Unable to install GRUB in /dev/sda"February 7

    I want to install a linux distribution on my computer. I have a SSD and an HDD. The SSD has Windows 8.1 and I partitioned 200 gigs from my 1 TB HDD to install linux. The linux installation was going smoothly until it reached the step where it needed

Copyright (C) 2017 ceus-now.com, All Rights Reserved. webmaster#ceus-now.com 14 q. 0.669 s.