Home > centos > Got an error while upgrading CentOS

Got an error while upgrading CentOS

February 29Hits:1
Advertisement

I'm upgrading my server but an error occurred. Here is the error report:

Transaction Check Error:   package subversion-1.6.15-0.1.el5.rfx.x86_64 (which is newer than subversion-1.6.11-7.el5_6.4.i386) is already installed   file /usr/share/emacs/site-lisp/psvn.el from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64   file /usr/share/locale/zh_CN/LC_MESSAGES/subversion.mo from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64   file /usr/share/xemacs/site-packages/lisp/psvn.el from install of subversion-1.6.11-7.el5_6.4.i386 conflicts with file from package subversion-1.6.15-0.1.el5.rfx.x86_64 

Answers

You already have a version installed.

You can try to clean using

rpm -e --nodeps --allmatches <packagename>

This will erase all packages that match the packagename and not check the dependencies before it does. After that you should be able to yum update successfully.

This means that a newer version of the package than the one in the upgrade is already installed. This should work right if you tell the upgrade to use the updates for the upgraded version.

In any case, CentOS really doesn't need to be upgraded explicitly during a series. That is, if you originally installed CentOS 5.0 and updated rigurously, by the time CentOS 5.2 comes out you already have that installed through package updates. CentOS 5.2 just rolls all the updates into one installable set. You'd need to upgrade when CentOS 6.0 comes out, or upgrade directly to, say, CentOS 6.2.

Related Articles

  • Got an error while upgrading CentOSFebruary 29

    I'm upgrading my server but an error occurred. Here is the error report: Transaction Check Error: package subversion-1.6.15-0.1.el5.rfx.x86_64 (which is newer than subversion-1.6.11-7.el5_6.4.i386) is already installed file /usr/share/emacs/site-lisp

  • SASL Error, after upgrading CentOS 5.2May 8

    Hello, Here is what happened: After the running of "yum upgrade" postfix was updated and the the connection with MySQL was lost, restore the version following the Perfect Server Setup Tutorial and restoring the .rpmsave files on the postfix dire

  • Can't Upgrade Centos to 5.6 / Dependency ErrorsApril 22

    Tried these steps: http://www.how2centos.com/upgrading-centos-5-5-to-centos-5-6/ When I run yum update, I get the below http://tinypaste.com/c8d9b2 Its not really 5.6, because I was originally on 4.8, then 5.3 and now these errors (even though it sho

  • upgrade CentOS from 6.5 to 7 in an EC2 InstanceSeptember 15

    How can I upgrade CentOS from 6.5 to 7.0 under Amazon Web Services EC2 instance? I have added the redhead upgrade tool to my repository and installed it, called the preupg and then imported the CentOS 7 GPG and then called: redhat-upgrade-tool --netw

  • SVN repo not found after upgrading centos 6.4 to 6.5October 1

    I installed svn client centos 6.4 but it was not working and throwing an error and not checking out the project. I googled it around and find a blog stating to upgrade centos. So i did upgrade and svn still didnt work out. Then after I re-installed a

  • Upgrade CentOS 4.4 to 4.8January 28

    I'm new to CentOS, have mainly worked with FreeBSD. How do i update/upgrade CentOS from version 4.4 to 4.8 ? Update # yum upgrade Will this upgrade only minor or will it upgrade to 5.x ? --------------Solutions------------- Upgrading from 4.4 to 4.8

  • Two major error after upgrading drupal from 5.9 to 6.22 December 14

    Possible Duplicate: Error when upgrading from 6.22 to 7.8 After upgrading on every save I get blank page with these 2 warnings: Warning: Table 'TheBIgBrother.languages' doesn't exist query: SELECT * FROM languages ORDER BY weight ASC, name ASC in /mo

  • debootstrap error while upgrading from 10.04 to 12.04 January 24

    I made a version upgrade with apt-get dist-upgrade and I had this error while upgrading packages: 2013-01-24 08:49:32 upgrade debootstrap 1.0.37ubuntu1~lucid1 1.0.39ubuntu0.2 2013-01-24 08:49:32 status half-installed debootstrap 1.0.37ubuntu1~lucid1

  • How to solve the pkgProblemResolver Error when upgrading to 12.04?March 11

    I am trying to upgrade my machine from 10.04 to 12.04 LTS but I get the following error. The same error occurs both in GUI and in terminal while doing dist-upgrade. E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held pac

  • error in upgrading ubuntu distributionMarch 27

    My ubuntu distribution upgrade got corrupted. As per suggestion from ubuntu distribution upgrade got corrupted I ran apt-get install -f to remedy the immediate problem. Now while running do-release-upgrade -d I get the following error - Upgrading app

  • SharePoint 2013 Migration - WideListSchema error is upgrade blockingApril 15

    I have a SharePoint 2007 site that has a list with a lot of fields, We are trying to migrate this site to SharePoint 2013 (with a hop on SharePOint 2010). The site gets upgraded onto SharePOint 2010 but when we upgrade it to SharePoint 2013, we recei

  • Is there any such error logged by CentOS somewhere that can conclusively reveal "it is now time to pay for ECC"September 14

    I have a 32GB non-ECC RAM dedicated server with CentOS. Once for day it randomly crashes without any error in /var/log/kern.log, /var/log/messages, mysql, apache. CPU/RAM/IO are not particularly high nor low. Is there any such error logged by CentOS

  • Lost web permission after upgrading CentOS from 5.6 to 5.10January 7

    I upgraded CentOS from 5.6 to 5.10 using the following simple commands while logged in as root: yum update yum upgrade Now, I can no longer access web pages. All requests, regardless of type of file requested (.html, .txt, .php) yield: Forbidden You

  • Error on Upgrade to sharepoint 2013March 18

    I'm trying to upgrade a webApp from 2007 to 2013. Following this tutorial: Tutorial The migration process to 2010 works perfectly . But When I try to do the same process to 2013, it breaks on 30% and the powershell returns me the error "cannot upgrad

  • upgrade centos 4.5 to 4.6 without affecting kernelMay 15

    I have to upgrade centOS 4.5 to centOS 4.6 without affecting the kernel.Is there any way to do this? --------------Solutions------------- Take a look here: http://lists.centos.org/pipermail/centos/2005-May/003904.html

  • Udev error while upgradingAugust 3

    I update and upgrade my ubuntu 14.04 server. Update is successfull but i get this error while upgrading : apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded,

  • Upgrading centOS 6.6 to 7January 4

    I have recently upgraded centOS 6.6 to 7. It seemingly boots up, but it can not open the log in page, Actually the systems is frozen here. Does anybody have similar experience? If so, it would be great to help with this. --------------Solutions------

  • Upgrade Centos to 6.5 not 6.6?June 29

    We are running Cassandra, specifically Datastax's Enterprise version in our production CentOS environment. As such, I wanted to upgrade our machines from an older CentOS 6.3 version to 6.5, the reason I don't want to upgrade all the way to 6.6 is tha

  • Error while upgrading to windows 10 proAugust 9

    I got a error while upgrading to windows 10 pro from windows 7 ultimate. It's a legal version! By restarting and loading win 10 pro he gave the blue screen error c1900101-20017 and then he restart to win 7 ultimate. Does anyone know how to solve that

  • After upgrading Centos 7.1 today, I find myself with the error kdump can't read /boot/ September 16

    After a yum update in CentOS 7.1, kdump is acting up. First off: [[email protected] ~]# cat /etc/centos-release CentOS Linux release 7.1.1503 (Core) [[email protected] ~]# systemctl status kdump kdump.service - Crash recovery kernel arming Loaded: loaded (/u

Copyright (C) 2017 ceus-now.com, All Rights Reserved. webmaster#ceus-now.com 14 q. 0.505 s.