Home > other > Help installing perl Net::Interface module

Help installing perl Net::Interface module

October 15Hits:1
Advertisement

Hello All,

I am trying to install PacketFence under Ubuntu 11.10 the installation succeeded but when i am executing the configurator.pl is ending with error module missing showed below i tried install the module as follows

Code:

  perl -MCPAN -e 'install Net::Interface'

I get error
Please advise
Thanks

Code:

  make: *** [test_dynamic] Error 255    MIKER/Net-Interface-1.012.tar.gz    /usr/bin/make test -- NOT OK  //hint// to see the cpan-testers results for installing this module, try:    reports MIKER/Net-Interface-1.012.tar.gz  Running make install    make test had returned bad status, won't install without force

I f someone could help resolve this missing perl module some how

error during running configuration

Code:

  @gfn-srv-secmnn:/home/pf#./configurator.pl                                                                                                            Can't locate Net/Interface.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at ./configurator.pl line 60.  BEGIN failed--compilation aborted at ./configurator.pl line 60 (#1)      (F) You said to do (or require, or use) a file that couldn't be      found. Perl looks for the file in all the locations mentioned in @INC,      unless the file name included the full path to the file.  Perhaps you      need to set the PERL5LIB or PERL5OPT environment variable to say where      the extra library is, or maybe the script needs to add the library name      to @INC.  Or maybe you just misspelled the name of the file.  See      perlfunc/require and lib.    Uncaught exception from user code:          Can't locate Net/Interface.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.12.4 /usr/local/share/perl/5.12.4 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.12 /usr/share/perl/5.12 /usr/local/lib/site_perl .) at ./configurator.pl line 60.  BEGIN failed--compilation aborted at ./configurator.pl line 60.   at ./configurator.pl line 60

I get error
Please advise
Thanks

--------------Solutions-------------

Can you try this?

Code:

wget http://search.cpan.org/CPAN/authors/id/M/MI/MIKER/Net-Interface-1.012.tar.gz
tar xvfz Net-Interface-1.012.tar.gz
cd Net-Interface-1.012
perl Makefile.PL
make
make test
make install
Tags:

Related Articles

  • Help installing perl Net::Interface moduleOctober 15

    Hello All, I am trying to install PacketFence under Ubuntu 11.10 the installation succeeded but when i am executing the configurator.pl is ending with error module missing showed below i tried install the module as follows Code: perl -MCPAN -e 'insta

  • How can I install Perl's DBI module on Ubuntu?November 10

    While I am trying to install perl modules-DBI i am getting this kind of error Permission denied at /usr/local/share/perl/5.8.8/CPAN/HandleConfig.pm line 554 --------------Solutions------------- sudo aptitude install libdbi-perl try to do that from ro

  • How to install Perl Switch.pm module required to build WebKit-GTK?October 22

    I noticed that the perl version (5.14) shipped with 12.10 does not include the Switch.pm module needed while building WebKiT-GTK. Looking around on the internet I found few suggestions indicating that I should install something call p5-switch from po

  • What is the 'best practice' for installing perl modules on Solaris/OpenSolaris?May 12

    I'm currently in the process of writing setup instructions for some software I've written that is implemented as a set of Perl modules. Having done this for various flavours of Linux, I'm now doing the same for Solaris/OpenSolaris (v10 only). Part of

  • Perl, Solaris: CPAN module install failed. How can I find out why?August 6

    I'm trying to install the File::Tail module using CPAN an older Solaris 10 (SunOS 5.10) box. I get an error when trying to install the module, but I see no indication why this failed anywhere in the CPAN output. I only see a "NOT OK" message. I

  • Installing perl moduleNovember 23

    How to install perl module Util.pm .I am missing this module .What is the procedure to install a perl module --------------Solutions------------- Regardless of which platform you may be on, you may be able to install the module using the CPAN shell.

  • How to install Perl module Crypt::OpenSSL::AES?August 29

    It's been a couple of days I am pulling my hair trying to get a legacy Perl script working as cgi within an apache2 server. It requires Crypt::OpenSSL::AES. From the Apache error logs: Can't locate Crypt/OpenSSL/AES.pm in @INC The easiest would have

  • problem install perl modules

    problem install perl modulesApril 24

    Hi, i followed the perfect debian setup und run "perl -MCPAN -e shell" in the console. After this i wanted to install: install HTML:arser install DB_File install Net:NS but i always get an error: Code: Checking if your kit is complete... Looks g

  • Can't install Perl module Apache::SizeLimit on CentOSMay 30

    On a CentOS machine I have installed mod_perl: yum install mod_perl ... Package mod_perl-2.0.4-10.el6.i686 already installed and latest version Ok, now I want to install the Perl module Apache::SizeLimit, so I do (and get): yum install perl-Apache-Si

  • The Perfect SpamSnake - Ubuntu 8.04 LTS - Page 02 - Installing Perl Modules

    The Perfect SpamSnake - Ubuntu 8.04 LTS - Page 02 - Installing Perl ModulesFebruary 25

    Hi there, I'm planning to put the spamsnake in front of my M$ Exchange 2003 server and therefore I've stated on this SpamSnake installation. I'm getting stuck in this: 1.11 Install Perl Modules(Pre-requisites) I'm getting this when i try this command

  • How to install the PHP/Serialization module in Perl?August 19

    When running nfsen, my logs display: nfsen[24213]: ERROR: Can't locate PHP/Serialization.pm in @INC (you may need to install the PHP::Serialization module) (@INC contains: /usr/local/nfsen/plugins /usr/local/nfsen/libexec /etc/perl /usr/local/lib/per

  • How to install Perl on Ubuntu Server?November 30

    I'm trying to deploy an application which according to the documentation requires the following: 2.2.5. Perl LMS-MGC and the rest of Perl scripts requires also Perl interpreter and some modules: Perl and its basic modules (POSIX, GetOpt::Long), Confi

  • Perl File::Copy module installation failsSeptember 26

    I have Perl version version 5.10.1 installed in my CentOS6.0 machine. I need to install TWiki and it needs some perl modules (see this URL) http://twiki.org/cgi-bin/view/TWiki/TWikiInstallationGuide I tried to install File::Copy module by going to Cp

  • How to install Perl, PHP, MySQL and Ruby packages on UbuntuFebruary 24

    I need to work on Perl, PHP, MySQL, and Ruby software on Ubuntu. Are these already installed on Ubuntu or do these packages need to be installed? I am using Ubuntu 12.04. --------------Solutions------------- To install PHP and MySQL on Ubuntu 12.04,

  • How do i install Perl 5.10.1 on Debian, using the packaging system?March 3

    I have little to no idea about administrating Debian, but I would like to at least use that release of Perl. Googling has proven unfruitful, so i turn to you, Stackoverflow. Note: Managed to find the solution already, this explains how to enable inst

  • How to Install Perl 6July 4

    I am trying to install Perl 6 and try few programs myself. Unlike other Perl distribution, I dont know how to install Perl 6. If any one you have already installed it and know the steps, please pass it on. Any links and manuals are greatly appreciate

  • Can't install perl-suid on Debian 5May 11

    I'm trying to install perl-suid needed for some script I've downloaded and getting the following $ sudo apt-get install perl-suid The following packages have unmet dependencies: perl-suid: Depends: perl (= 5.10.0-19lenny3) but 5.10.1-17 is to be inst

  • How to install Perl Power Tools on WindowsJune 9

    Are the Perl Power Tools still around? I'm trying to install them on Windows Server 2008 with Strawberry Perl. If I search the web I get: http://sourceforge.net/projects/ppt/ as first link, where I read "As of 2004-08-06, this project may now be foun

  • Mac Ports keeps on re-installing Perl, Python, etcFebruary 8

    Every time I want to install something, mac ports keeps on re-installing Perl, Python, etc. although the same packages are already installed on the system. Is there some setting to avoid this? --------------Solutions------------- What you are seeing

  • Set Update Manager to install to sites/all/modules/contrib?March 4

    I am able to use Update Manager to install new modules, instead of having to manually upload them. I previously put everything in sites/all/modules, but now have reorganized my modules into sites/all/modules/contrib and sites/all/modules/custom (for

Copyright (C) 2017 ceus-now.com, All Rights Reserved. webmaster#ceus-now.com 14 q. 1.077 s.