Home > apt > How to tell apt-get to install another version of Eclipse?

How to tell apt-get to install another version of Eclipse?

February 17Hits:2
Advertisement

apt-get installs Eclipse version 3.5 when I do this:

sudo apt-get install eclipse-platform 

However I would like to install version 3.6.
How can I do that?

Answers

Eclipse 3.5 is the latest version in repositories.apt-get installs the latest version automatically, so there is nothing to do with apt-get.

Instead you can download eclipse 3.6 (Helios) from eclipse.org and use it.

You can tell apt to install a specific version as follows:

apt-get install package=version

example:

apt-get install eclipse-platform=3.5.2-6ubuntu1.1

But AFAIK the version 3.6 is not available in the repo. It is better to install manually . Check a similar thread here How to install Eclipse.

Tags:apt

Related Articles

  • How to tell apt-get to install another version of Eclipse?February 17

    apt-get installs Eclipse version 3.5 when I do this: sudo apt-get install eclipse-platform However I would like to install version 3.6. How can I do that? --------------Solutions------------- Eclipse 3.5 is the latest version in repositories.apt-get

  • apt-get cannot install specific version listed in apt-cache policyFebruary 16

    I'm trying to install a particular version of redis-server from a third-party repo using apt-get, that's listed in apt-cache policy, but cannot be installed. For example: $ apt-cache policy redis-server redis-server: Installed: (none) Candidate: 2:2.

  • How to make apt recognize an installed tar package?August 8

    I've installed Oracle Java. I want to be able to remove OpenJDK, but when trying to do so apt wants to install another version of Java. How can I configure apt so that it knows I already have a third-party Java installed so I can remove these OpenJDK

  • How can I get apt-get to install python packages for a different version of python?October 27

    In Ubuntu 10.10, I have installed python 2.7. I would like to use apt-get to install packages to this version of python but I haven't been able to figure out how. Things I have tried without success: changing the symlink at /usr/bin/python to point t

  • how to run `apt-get -f install'December 26

    You might want to run `apt-get -f install' to correct these. it says that everytime i try to download something and when i type it in the terminal it says E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock

  • How can I install multiple versions of Firefox (4.0 and 3.6), preferably using aptApril 7

    I have the firefox package (Firefox 3.6) installed in Ubuntu 10.04. I'd like to install Firefox 4.0 from the Mozilla PPA but keep 3.6? The instructions look like they'll replace the current firefox package with the new firefox. Is it possible to inst

  • How do I ignore unmet dependencies when using apt-get -f install?June 8

    I'm trying to use apt-get to install imagick. Should be simple enough. This is my command. apt-get install imagemagick libmagickcore-dev libmagickwand-dev However instead of installing it keeps bouncing back with this error message The following pack

  • apt-get has unmet dependencies, but apt-get -f install doesn't solve problemJune 29

    I've tried to install emacs on Ubuntu server 64bit 11.04, but it's complaining about emacs23-common. If I do: sudo apt-get -f install I still see the same problem: Errors were encountered while processing: /var/cache/apt/archives/emacs23-common_23.2+

  • Terminal says 'Broken package' when using apt-get to install phpMyAdminOctober 5

    I have tried to install phpMyAdmin using the sudo apt-get install phpmyadmin command> The terminal says that there are "uninstallable" dependencies, therefore the package is broken.Perhaps the following copy-paste from the terminal will expla

  • How to tell the version of jetty that apt-get will install?January 14

    Is it possible to see what version of jetty will be installed on the various versions of Ubuntu? Is it online somewhere? Also, is it possible to see the package so I can tweak it if required? --------------Solutions------------- There are a couple of

  • Cannot install anything through Terminal - apt-get -f installMay 7

    I get this when ever i try and install anything with th Terminal: You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: gimp : Depends: libgimp2.0 (<= 2.6.12-z) but 2.8.0-1ubuntu0ppa3~precise is

  • Try 'apt-get -f install' with no packages

    Try 'apt-get -f install' with no packages May 21

    Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages

  • How do you recover from a failed upgrade ('apt-get -f install' and 'dpkg --configure -a' fail)?June 19

    During an upgrade from lucid (10.04) to precise (12.04), the X session froze, and I have been trying to recover the upgrade to get a stable system. I have performed the following steps: Used ssh to log in to the stalled system over the network. Check

  • apt-get install fails due to dependency issues but apt-get -f install won't fix itJune 20

    I've just installed Ubuntu 12.04 and was about to manually install Rawstudio with the packages from SourceForge repo, but I've been stuck with dependency issues and I am short on apt command lines to sort this out. Here's the report I'v got : install

  • apt-get -f install gives errorJune 20

    When I run apt-get -f install, it gives the following error: # apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically insta

  • How do I tell apt not to install X11 & gnome dependencies cause I will use X11 forwarding?July 16

    I want to run virt-manager from the server itself (so that I can use the interface management feature which is not available over ssh connection). However, I plan to launch virt-manager over an ssh connection forwarding X11 to my laptop where I run a

  • Broken Package Manager? The suggested "apt-get -f install" is failing!August 2

    I don't really know what happened... I clicked "install updates" in the update manager window, it failed, and next thing I know I can't apt-get install any packages, it just suggests I try apt-get -f install, which fails with the following messa

  • apt-get: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)September 1

    [email protected]:/home/m/Desktop# apt-get -f install libc6 Reading package lists... Done Building dependency tree Reading state information... Done libc6 is already the newest version. libc6 set to manually installed. You might want to run `apt-get -f i

  • "apt-get -f install" fails with "/usr/bin/dpkg returned an error code (1)" September 15

    Possible Duplicate: Fixing Broken Packages I started out trying to install CVS: $ sudo apt-get install cvs Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct

  • apt-get -f install is stuck on "corrupted filesystem tarfile"September 24

    I am having issues with apt-get on my Raspberry Pi. This is the output when I try and install a package: [email protected] ~ $ sudo apt-get -f install cowsay Reading package lists... Done Building dependency tree Reading state information... Done You mi

Copyright (C) 2017 ceus-now.com, All Rights Reserved. webmaster#ceus-now.com 14 q. 0.563 s.